Search not working after INSTALL
You need to point the search box to the location of existing Ontolica Search Center.
Go to: “Home > Site Actions > Site Settings > Modify All Site Settings > Ontolica Search Box Scopes”.
Choose “Settings”. Set the “Target Search Center” to the URL you specified when creating the Ontolica Search Center.

Search not working after UPGRADE
If the image search page gives you a “page cannot be found” you can deactivate and then activate Ontolica on the site collection to make sure that it is using the latest XSLTs.
If that doesn’t work then you can try and remove the old XSLT and then do a deactivate/activate Ontolica. Then the new XSLT should be copied in correctly.
This is where you can find the XSLT: Site Settings -> Ontolica Styles -> Search Results -> Images.You may need to do a page refresh (Ctrl + F5) before the site is displayed correctly.
Ontolica caches the XSLT’s.If this still doesn’t give you Image Search and you are still receiving a “page not found” it might be having issues with finding the search page.
This can be checked by hovering over the Image tab and see what page it links to.Then go to Site Actions > Manage Content and Structure and see if the file exist. If it does not, then you need to delete the search center and create a new one.
Please remember that if the settings you made to the site was made on site level, then they will be lost.
This is why we recommend that you make the settings on the site collection level. This way your settings will remain even after you remove the old search center to create the new.

Need more help with this?

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.